முக்கிய பிசி & மேக் மின்னஞ்சல்கள் வழக்கு உணர்திறன் உள்ளதா?

மின்னஞ்சல்கள் வழக்கு உணர்திறன் உள்ளதா?



மின்னஞ்சல் முகவரிகள் வழக்கு உணர்திறன் கொண்டவையா இல்லையா என்பதில் நிறைய குழப்பங்கள் உள்ளன. சிலர் அவர்கள் என்று கூறுகிறார்கள், மற்றவர்கள் அவர்கள் இல்லை என்று கூறுகிறார்கள். எனவே, யார் சரி? இந்த கட்டுரையில், மின்னஞ்சல் முகவரிகள் வழக்கு உணர்திறன் கொண்டவையா அல்லது வழக்கு உணர்வற்றவையா என்பதைப் பார்ப்போம்.

மின்னஞ்சல்கள் வழக்கு உணர்திறன் உள்ளதா?

மின்னஞ்சல் முகவரியை உருவாக்குவது எது?

ஒரு மின்னஞ்சல் முகவரி மூன்று பகுதிகளால் ஆனது - உள்ளூர் பகுதி (பயனர்பெயர் என்றும் அழைக்கப்படுகிறது), @ அடையாளம் மற்றும் டொமைன் பகுதி. ஒவ்வொரு பகுதிக்கும் அதன் சொந்த பங்கு உள்ளது மற்றும் அதன் சொந்த விதிகளுக்கு உட்பட்டது. விரைவான கண்ணோட்டம் இங்கே.

தரத்தின்படி, மின்னஞ்சல் முகவரியின் உள்ளூர் பகுதி 64 எழுத்துக்கள் வரை நீளமாக இருக்கலாம் மற்றும் வரையறுக்கப்பட்ட எழுத்துக்குறிகளால் ஆனது. இவற்றில் மேல் மற்றும் கீழ் எழுத்து லத்தீன் எழுத்துக்கள், 0 முதல் 9 வரையிலான எண்கள், புள்ளி மற்றும் சிறப்பு எழுத்துக்கள் அடங்கும். சிறப்பு எழுத்துக்களில் `[மின்னஞ்சல் பாதுகாக்கப்பட்ட] # $% ^ & * () _- + = [] {} include அடங்கும். இது டொமைன் பகுதியுடன் @ அடையாளத்துடன் இணைக்கப்பட்டுள்ளது.

டொமைன் பகுதி 255 எழுத்துகள் வரை இருக்கலாம். இது லத்தீன் எழுத்துக்களின் எழுத்துக்கள் (கீழ் மற்றும் மேல் வழக்கு), 0 முதல் 9 வரையிலான எண்கள் மற்றும் ஹைபன் ஆகியவற்றைக் கொண்டிருக்கலாம். ஹைபன் டொமைன் பகுதியைத் தொடங்கவோ முடிக்கவோ முடியாது.

சர்வதேச சின்னங்களையும் பயன்படுத்தலாம், ஆனால் பின்னர் அதைப் பற்றி அதிகம்.

இது வழக்கு உணர்திறன் உள்ளதா?

இந்த கேள்விக்கு சரியான பதில் ஆம் மற்றும் இல்லை. படி RFC 5321 , மின்னஞ்சல் முகவரியின் உள்ளூர் பகுதி வழக்கு உணர்திறன் கொண்டது. இதன் பொருள், கோட்பாட்டில், [மின்னஞ்சல் பாதுகாக்கப்பட்டவை] [மின்னஞ்சல் பாதுகாக்கப்பட்டவை] போலவே இல்லை, இருப்பினும், உள்ளூர் பகுதிகளை வழக்கு உணர்திறன் மற்றும் வழக்கு உணர்வற்றதாக கருதுவதற்கு மின்னஞ்சல் வழங்குநர்களுக்கு சுதந்திரம் உள்ளது.

எடுத்துக்காட்டாக, [மின்னஞ்சல் பாதுகாக்கப்பட்ட], [மின்னஞ்சல் பாதுகாக்கப்பட்ட] மற்றும் [மின்னஞ்சல் பாதுகாக்கப்பட்ட] கோட்பாட்டளவில் வேறுபட்ட மின்னஞ்சல் முகவரிகள். ஒரு அஞ்சல் சேவையகம் உள்ளூர் பகுதிகளை வழக்கு உணர்திறன் எனக் கருதினால் இது எவ்வாறு சிக்கல்களை உருவாக்கும் மற்றும் பயனர் அனுபவத்தை குறைக்கும் என்பதைக் காண்பது எளிது. எனவே, பல வழங்குநர்கள் மின்னஞ்சல் முகவரியின் உள்ளூர் பகுதியை வழக்கு உணர்வற்றதாக கருதுகின்றனர்.

விளையாட்டில் முரண்பாடு மேலடுக்கை எவ்வாறு முடக்கலாம்

டொமைன் பகுதியைப் பொறுத்தவரை, RFC 1035 இது எப்போதுமே வழக்கு உணர்வற்றதாக இருக்கும் என்று விதிக்கிறது. இதன் பொருள் நீங்கள் இதை சிறிய வழக்கு, மேல் வழக்கு அல்லது இரண்டின் எந்தவொரு கலவையிலும் எழுதலாம் மற்றும் உங்கள் மின்னஞ்சல் ஒரே முகவரியில் முடிவடையும். நடைமுறை பயன்பாட்டில், [மின்னஞ்சல் பாதுகாக்கப்பட்ட], [மின்னஞ்சல் பாதுகாக்கப்பட்ட] மற்றும் [மின்னஞ்சல் பாதுகாக்கப்பட்ட] ஒரே மின்னஞ்சல் முகவரி.

நடைமுறையில்

மின்னஞ்சல் முகவரிகள் ஓரளவு வழக்கு உணர்திறன் கொண்டவை என்றாலும், அவற்றை வழக்கு உணர்வற்றவை என்று நினைப்பது பொதுவாக பாதுகாப்பானது. ஜிமெயில், யாகூ மெயில், ஹாட்மெயில் மற்றும் பிற முக்கிய வழங்குநர்கள் மின்னஞ்சல் முகவரிகளின் உள்ளூர் பகுதிகளை வழக்கு உணர்வற்றதாக கருதுகின்றனர். இவ்வாறு கூறப்பட்டால், நீங்கள் ஒரு மின்னஞ்சலை உருவாக்க விரும்பும் மின்னஞ்சல் வழங்குநரின் விதிகளை சரிபார்க்க வேண்டும்.

முந்தைய புள்ளியுடன் இணைந்தால், மேலே குறிப்பிடப்பட்ட RFC 5321 புதிய மின்னஞ்சல் முகவரிகளை சிறிய எழுத்துக்களுடன் உருவாக்க பரிந்துரைக்கிறது, இது குழப்பம் மற்றும் விநியோக சிக்கல்களைத் தவிர்க்க மட்டுமே.

மறுபுறம், உங்கள் நண்பர் அல்லது சக ஊழியருக்கு மேல் வழக்கு மற்றும் சிறிய எழுத்துக்களின் கலவையுடன் ஒரு மின்னஞ்சல் முகவரி இருந்தால், நீங்கள் அவர்களுக்கு மின்னஞ்சல் அனுப்பும்போது அதைப் போலவே எழுதுவது நல்லது. அவ்வாறு செய்யத் தவறினால் மின்னஞ்சல் வழங்கப்படாமல் போகலாம். இருப்பினும், இது முக்கிய மின்னஞ்சல் வழங்குநர்களான ஜிமெயில், யாகூ மெயில், ஹாட்மெயில் மற்றும் பிறவற்றில் உள்ள பிரச்சினை அல்ல.

கூடுதலாக, பயனரின் கணக்கு அடையாளம் காணும்போது மின்னஞ்சலின் உள்ளூர் பகுதியில் காணப்படும் புள்ளிகளுக்கும் ஜிமெயில் உணர்ச்சியற்றது. இதன் பொருள் [மின்னஞ்சல் பாதுகாக்கப்பட்ட] கணக்கு இருந்தால், நீங்கள் [மின்னஞ்சல் பாதுகாக்கப்பட்ட] அல்லது [மின்னஞ்சல் பாதுகாக்கப்பட்ட] பதிவு செய்ய முடியாது.

சர்வதேசமயமாக்கல்

முதலில், லத்தீன் எழுத்துக்கள், எண்கள் மற்றும் வரையறுக்கப்பட்ட சிறப்பு ஆஸ்கி எழுத்துக்களின் எழுத்துக்களைப் பயன்படுத்தி மட்டுமே மின்னஞ்சல் முகவரிகளை பதிவு செய்ய முடியும். எனினும் IETF (இணைய பொறியியல் பணிக்குழு) பின்னர் சர்வதேச எழுத்துக்களைச் சேர்ப்பதற்கான விதிகளையும் தரங்களையும் உருவாக்கியுள்ளது.

RFC6530 சர்வதேச எழுத்துக்களின் பயன்பாட்டைச் சேர்த்து ஒழுங்குபடுத்திய முதல் நபர். RFC6531 விதிகள் மற்றும் தரநிலைகளில் விரிவாக்கப்பட்டது. பின்னர், விதிகள் மற்றும் தரநிலைகள் மூலம் புதுப்பிக்கப்பட்டன RFC6532 மற்றும் RFC6533 .

நீங்கள் இப்போது பரந்த அளவிலான எழுத்துக்கள், எழுத்துக்கள் மற்றும் ஸ்கிரிப்ட்களைப் பயன்படுத்தி மின்னஞ்சல் முகவரியைப் பதிவு செய்யலாம். லத்தீன் எழுத்துக்கள், கிரேக்க எழுத்துக்கள், பாரம்பரிய சீன எழுத்துக்கள், ஜப்பானிய எழுத்துக்கள் (ஹிரகானா, கட்டகனா மற்றும் காஞ்சி), சிரிலிக் எழுத்துக்கள், பல இந்திய ஸ்கிரிப்டுகள் மற்றும் பலவற்றைக் கொண்டவை மிகவும் பரவலாகப் பயன்படுத்தப்படுகின்றன.

சர்வதேச மின்னஞ்சல் முகவரிகளுடன் சேர்ப்பது மற்றும் பொருந்தக்கூடியது வழங்குநருக்கு வழங்குநருக்கு மாறுபடும். சில பெரிய வழங்குநர்கள் கூட சர்வதேச முகவரிகளுடன் முழுமையாக பொருந்தவில்லை. எடுத்துக்காட்டாக, ஒரு சர்வதேச முகவரிக்கு மின்னஞ்சல் அனுப்ப Google உங்களை அனுமதிக்கிறது, ஆனால் ஒன்றை உருவாக்க இது உங்களை அனுமதிக்காது. அவுட்லுக் 2016 இதே போன்ற செயல்பாட்டைக் கொண்டுள்ளது.

முடிவுரை

டொமைன் பெயர் பகுதியைப் போலன்றி, மின்னஞ்சல் முகவரியின் உள்ளூர் பகுதி வழக்கு உணர்திறன் கொண்டது. இவ்வாறு கூறப்பட்டால், பல மின்னஞ்சல் வழங்குநர்கள் நடைமுறை காரணங்களுக்காக உள்ளூர் பகுதியின் வழக்கு உணர்திறனைப் புறக்கணிக்கத் தேர்வுசெய்கிறார்கள் மற்றும் சிறிய எழுத்துக்களை மட்டுமே கொண்ட மின்னஞ்சல்களை உருவாக்க மக்களை ஊக்குவிக்கிறார்கள்.

சுவாரசியமான கட்டுரைகள்

ஆசிரியர் தேர்வு

அனைத்து நீராவி கிளவுட் சேமிப்புகளையும் நீக்குவது எப்படி
அனைத்து நீராவி கிளவுட் சேமிப்புகளையும் நீக்குவது எப்படி
பல பிசி கேமர்கள் நீராவியை விரும்புகிறார்கள், ஏனெனில் இது அவர்களின் கேம்களை வசதிக்காக ஒரே பயன்பாட்டில் ஒழுங்கமைக்க உதவுகிறது. சேவையானது உங்கள் கேமின் கோப்புகளை மேகக்கணியில் காப்புப் பிரதி எடுக்கிறது, இதன் மூலம் எந்த கணினியிலும் இந்த தலைப்புகளை இயக்க முடியும். இருப்பினும், மேகம்
டெர்ரேரியாவில் சிறந்த கவசம் எது? ஒரு முழு பட்டியல்
டெர்ரேரியாவில் சிறந்த கவசம் எது? ஒரு முழு பட்டியல்
டெர்ரேரியாவில் பிளேயரின் முழுமையான தேடல்கள் மற்றும் அதிக அனுபவத்தைப் பெறுவதால், அவை சில சிறந்த அம்சங்களையும் திறக்கின்றன. ஆயுதங்கள் மற்றும் பாகங்கள் தவிர, உங்கள் கவச விருப்பங்கள் காலப்போக்கில் மேம்படும். இது மிகவும் முக்கியமானது, ஏனெனில் சிறந்த கவசம் உங்களை அனுமதிக்கிறது
பிஎஸ் 5 கன்ட்ரோலர் இணைக்கப்படாவிட்டால் அதை எவ்வாறு சரிசெய்வது
பிஎஸ் 5 கன்ட்ரோலர் இணைக்கப்படாவிட்டால் அதை எவ்வாறு சரிசெய்வது
உங்கள் PS5 கட்டுப்படுத்தி USB அல்லது வயர்லெஸ் மூலம் PS5 உடன் இணைக்கப்படாவிட்டால் அல்லது ஒத்திசைக்கவில்லை என்றால், வேறு கேபிளைப் பயன்படுத்தவும் அல்லது பிற புளூடூத் சாதனங்களைத் துண்டிக்கவும்.
டோர் டாஷில் உங்கள் உதவிக்குறிப்பை மாற்றுவது எப்படி
டோர் டாஷில் உங்கள் உதவிக்குறிப்பை மாற்றுவது எப்படி
https://www.youtube.com/watch?v=wOfcVxB4Ez8 டெலிவரி நபர்கள், உணவகங்கள் மற்றும் வாடிக்கையாளர்கள் அனைவரும் DoorDash பயன்பாட்டைப் பயன்படுத்துகின்றனர். உங்கள் ஆர்டரை நீங்கள் வைக்கும்போது, ​​உங்கள் டெலிவரி வருவதற்கு முன்பு கிராச்சுட்டியை (ஒரு உதவிக்குறிப்பு) சேர்க்கலாம். இந்த கட்டுரை அளவை எவ்வாறு மாற்றுவது என்பதை விளக்குகிறது
கிளாசிக் டெஸ்க்டாப் ஸ்கைப் பதிப்பு 7 ஐ பதிவிறக்கவும்
கிளாசிக் டெஸ்க்டாப் ஸ்கைப் பதிப்பு 7 ஐ பதிவிறக்கவும்
மைக்ரோசாப்ட் நல்ல பழைய கிளாசிக் ஸ்கைப்பை தங்கள் அதிகாரப்பூர்வ வலைத்தளத்திலிருந்து நீக்கியுள்ளது. இது ஏன் நடந்தது மற்றும் டெஸ்க்டாப் பயன்பாட்டிற்கான கிளாசிக் ஸ்கைப்பை எவ்வாறு பதிவிறக்குவது என்பது இங்கே.
பணிநிறுத்தம் விண்டோஸ் 10 இல் உள்நுழைவது எப்படி
பணிநிறுத்தம் விண்டோஸ் 10 இல் உள்நுழைவது எப்படி
விண்டோஸ் 10 பணிநிறுத்தம் செயல்முறையை கண்காணிக்க மற்றும் கணினி பதிவில் பல நிகழ்வுகளை எழுத முடியும். இந்த கட்டுரையில், பணிநிறுத்தம் பதிவை எவ்வாறு கண்டுபிடிப்பது என்று பார்ப்போம்.
உங்கள் அமேசான் ஃபயர் ஸ்டிக்கில் YouTube குழந்தைகளை எவ்வாறு நிறுவுவது
உங்கள் அமேசான் ஃபயர் ஸ்டிக்கில் YouTube குழந்தைகளை எவ்வாறு நிறுவுவது
உங்களிடம் குழந்தைகள் இருந்தால், இணையத்தில் பொருத்தமற்ற உள்ளடக்கத்திலிருந்து அவர்களைப் பாதுகாப்பது எவ்வளவு முக்கியம் என்பது உங்களுக்குத் தெரியும். கவனமாக நிர்வகிக்கப்பட்ட YouTube இல் கூட, உங்கள் குழந்தை அவர்களுக்குப் பொருந்தாத உள்ளடக்கத்தில் இயங்க முடியும். அதனால்தான்